About Free Support

Understanding the Verbum "Free Support" Life-cycle.

There are three levels of free support for Verbum applications. To better understand your support options, please review the information below.

Current Software Status | October26, 2020

Support status for Verbum applications has changed to the following:

Supported Verbum 9.0+
Verbum 9.0+
Windows 10 "Anniversary Update" (Windows 10 Version 1607 or later)
macOS 10.14 and above
Maintenance

Logos 8.17+
Verbum 8.17+

Unsupported Verbum 7.19 and earlier
Libronix DLS
Verbum Library System
Beta versions of Windows and macOS
All distributions of Linux
Windows 8.1 and earlier
Windows RT
Windows 10 S / X
macOS 10.13 and earlier

 

Support Level Summary

A summary of the features and available support options by category are shown in this table:

Feature or Support
Supported
Maintenance
Unsupported
Textual Resources
Some
Sync Documents & Settings
Some
Access Web Services
Some
Critical Bug Fixes
 
Phone & Email Support
 
New Features
   
Non-Critical Bug Fixes
   
New OS Support
   
Old OS Compatibility  
Some
Some
Forum Support
Some
Some

Supported

Supported (current generation) applications receive the following: free online updates, all bug fixes, new features, access to the latest resources and data sets, ability to synchronize documents and settings, and come with access to our online support knowledge base as well as full email and telephone support.

Supported versions may require newer operating system versions in order to stay current. To pursue support for your current generation software, please use the following options:


Maintenance

Maintenance versions receive free updates online and can read the latest textual resources, but may not support newer data sets and features. They can sync documents and settings, will get critical bug fixes1, and have full email and telephone support. Maintenance versions may run on older operating system versions, but may not receive new features or access to new data sets.

 

To pursue support for your maintenance software, please use the following options:


Unsupported

Unsupported versions do not receive updates and may not have access to the latest resource files. Web services that are only used by unsupported versions may be discontinued without notice. Documents and settings created in an unsupported version may not sync to the latest versions of the software.

Telephone and email support are unavailable or extremely limited, but you can still request help in the forums. You may be required to update before receiving assistance.


Frequently Asked Questions

Q: Where can I download Verbum from?

A: You can install Verbum by following the instructions here.

 

I still have an older version of Verbum...

Q: Do I have to buy Verbum?
A: It is possible to order the Verbum Basic package which will get you access to the newer version of Verbum. There will be an installation link for Verbum after the order has been completed. If need be, you can then also install Verbum from the install page here.

Note: This free download contains a limited number of new features, resources, and books on an "access-only" basis. This means you can access them but you do not own them permanently. Consider a Base Package Upgrade.
Get an Upgrade Quote >>

Q: Will I lose anything I already own if I update?
A: No. Updating versions of Verbum never results in losing books or other resources.

 

I have an older version of Windows or Mac OS X...

Q: Will Verbum work on my computer?
A: Older operating systems (such as Windows XP or Vista, Mac OS X 10.10) do not support the newer software. You will need to upgrade your operating system or computer to something more current to use Verbum.

Q: Can I still use an unsupported version of Verbum?
A: Because of changes to SSL versions of Verbum before Verbum 7.19 will not be able to connect to our servers. This will result in not being able to use Verbum online.

 


1 While operating systems and versions of Verbum will continue to receive the same updates other versions of Verbum receive, updates, we will no longer test the application on these operating systems, nor deliver bug fixes that exclusively affect them.

Was this article helpful?
1 out of 3 found this helpful

We're sorry to hear that! Tell us why.

Have more questions? Ask the community.

Can't find what you need? Contact us!